summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-12-23 13:07:48 +0100
committer宋文武 <iyzsong@member.fsf.org>2023-01-29 09:03:16 +0800
commit7c56811c0468f9f843079eb91b2d925793b6ff5f (patch)
tree28ce8e410fed2c65e8aafb3bea9fd4e26c873c83
parentc3eab98ccd47e36fadeb1a24d09ffbf0da18d15d (diff)
downloadguix-7c56811c0468f9f843079eb91b2d925793b6ff5f.tar.gz
gnu: xfconf: Update to 4.18.0.
* gnu/packages/xfce.scm (xfconf): Update to 4.18.0.
[arguments]: Remove unneeded phase install-shell-completions.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/xfce.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index eee7d048b1..3522fe1b65 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -129,7 +129,7 @@ Xfce Desktop Environment.")
 (define-public xfconf
   (package
     (name "xfconf")
-    (version "4.16.0")
+    (version "4.18.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -137,7 +137,7 @@ Xfce Desktop Environment.")
                                   "xfconf-" version ".tar.bz2"))
               (sha256
                (base32
-                "09al5bkq89b8pb3xyxnw0cnz6crxj8678ymwq2k9nzf60y812ak5"))))
+                "01i9bn2v9mcfa03ndd9dyihz7yc1mnfzr550mq3sh07q1cb5131f"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -157,13 +157,6 @@ Xfce Desktop Environment.")
              ;; For the missing '/etc/machine-id'.
              (setenv "DBUS_FATAL_WARNINGS" "0")
              (invoke "dbus-launch" "make" "check")))
-         (add-after 'custom-check 'install-shell-completions
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (etc (string-append out "/etc")))
-               (with-directory-excursion "completions"
-                 (install-file "xfconf-query"
-                               (string-append etc "/bash_completion.d"))))))
          (delete 'check))))
     (native-inputs
      (list pkg-config