summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-24 23:01:31 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:13 -0500
commit7dc728c4b7e9f8eefc97e86bfa5678cdcbb05fbc (patch)
tree6dd3b339e6e0ec0dadaa35936ffea40e320fc39f
parent2d817e415b7fb06dbde329dc98efde0720a6d4c0 (diff)
downloadguix-7dc728c4b7e9f8eefc97e86bfa5678cdcbb05fbc.tar.gz
gnu: gnome-sudoku: Update to 3.32.0.
* gnu/packages/gnome.scm (gnome-sudoku): Update to 3.32.0.
[build-system]: Use meson-build-system.
[arguments]: Set glib-or-gtk? flag and add 'skip-gtk-update-icon-cache' phase.
[native-inputs]: Add glib:bin and vala.
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4785437323..69163c768d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3190,7 +3190,7 @@ floating in an ocean using only your brain and a little bit of luck.")
 (define-public gnome-sudoku
   (package
     (name "gnome-sudoku")
-    (version "3.30.0")
+    (version "3.32.0")
     (source
      (origin
        (method url-fetch)
@@ -3199,13 +3199,24 @@ floating in an ocean using only your brain and a little bit of luck.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "1xy986s51jnrcqwan2hy4bjdg6797yr9s7gxx2z2q4j4gkx3qa1f"))))
-    (build-system glib-or-gtk-build-system)
+         "1wwdjflw1lbx3cv6gvqcgp5jnjkrq37ld6mjbjj03g3vr90qaf0l"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           (lambda _
+             (substitute* "build-aux/post_install.py"
+               (("gtk-update-icon-cache") (which "true")))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("desktop-file-utils" ,desktop-file-utils)
+       ("glib:bin" ,glib "bin") ; for glib-compile-resources
        ("intltool" ,intltool)
        ("itstool" ,itstool)
+       ("vala" ,vala)
        ("xmllint" ,libxml2)))
     (inputs
      `(("gtk+" ,gtk+)