summary refs log tree commit diff
diff options
context:
space:
mode:
authorJacob MacDonald <jaccarmac@gmail.com>2019-07-11 15:42:10 -0500
committerLudovic Courtès <ludo@gnu.org>2019-07-13 15:13:52 +0200
commit7deb0868645fcf64803a026750251258b2101bad (patch)
tree24ba7a64145259369ead8e0939f228d7f2c6b3ae
parente308b4f06a06c38954b1c07c6a83622bb01a0326 (diff)
downloadguix-7deb0868645fcf64803a026750251258b2101bad.tar.gz
gnu: Add python-urllib3-1.24.
* gnu/packages/python-web.scm (python-urllib3-1.24): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e441cbaa81..04f53740e4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1528,6 +1528,18 @@ can reuse the same socket connection for multiple requests, it can POST files,
 supports url redirection and retries, and also gzip and deflate decoding.")
     (license license:expat)))
 
+;; Some software requires an older version of urllib3, notably Docker.
+(define-public python-urllib3-1.24
+  (package (inherit python-urllib3)
+           (version "1.24.3")
+           (source (origin
+                     (method url-fetch)
+                     (uri (pypi-uri "urllib3" version))
+                     (sha256
+                      (base32
+                       "1x0slqrv6kixkbcdnxbglvjliwhc1payavxjvk8fvbqjrnasd4r3"))))))
+
+
 (define-public python2-urllib3
   (package-with-python2 python-urllib3))