summary refs log tree commit diff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-11-19 21:45:39 -0500
committerMathieu Othacehe <othacehe@gnu.org>2020-11-25 13:43:35 +0100
commit7f1d093eae5f9dbb48b3760a7f108d30dc592af3 (patch)
treefe0d54ae01f8105ee8db84b3d393b7e3e38532de
parente28798057635284e3d53de7da4b6e46072a169ee (diff)
downloadguix-7f1d093eae5f9dbb48b3760a7f108d30dc592af3.tar.gz
gnu: git-annex: Update to 8.20201116.
If ghc-torrent isn't available, git-annex will fall back to custom legacy
code.  However, this older code path has a build failure in the 8.20201116
release, and in general it'd be better to rely on the preferred, more
exercised code path.

* gnu/packages/haskell-apps.scm (git-annex): Update to 8.20201116.
[inputs]: Add ghc-torrent.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/haskell-apps.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 1339536954..c6045279c0 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -339,14 +339,14 @@ to @code{cabal repl}).")
 (define-public git-annex
   (package
     (name "git-annex")
-    (version "8.20201103")
+    (version "8.20201116")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/"
                            "git-annex/git-annex-" version ".tar.gz"))
        (sha256
-        (base32 "1z9ikpsz3by48yfw87qav5dy7j4k9ky4a7nqnasl15kdm3lav9pl"))))
+        (base32 "0xv7n9f6l90l4k964675v0lgs22gcy97ic86mbfb40rl0fk0jalr"))))
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags
@@ -487,6 +487,7 @@ to @code{cabal repl}).")
        ("ghc-split" ,ghc-split)
        ("ghc-stm-chans" ,ghc-stm-chans)
        ("ghc-tagsoup" ,ghc-tagsoup)
+       ("ghc-torrent" ,ghc-torrent)
        ("ghc-unix-compat" ,ghc-unix-compat)
        ("ghc-unordered-containers" ,ghc-unordered-containers)
        ("ghc-utf8-string" ,ghc-utf8-string)