summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-17 10:30:50 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-22 08:42:53 +0800
commit826f188d52aa924e09b6480be334003a48742554 (patch)
treecd48b7b456120eee6e6c04f6b31e577ed2152aa7
parente8b4c9af4b517c0d34d18f620aec7f59032ede20 (diff)
downloadguix-826f188d52aa924e09b6480be334003a48742554.tar.gz
gnu: lxqt-notificationd: Update to 1.1.0.
* gnu/packages/lxqt.scm (lxqt-notificationd): Update to 1.1.0.
[arguments]: Remove phases.
-rw-r--r--gnu/packages/lxqt.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 2d249f4ed1..c2f1c054e1 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -453,14 +453,14 @@ as a whole and are not limited to distinct applications.")
 (define-public lxqt-notificationd
   (package
     (name "lxqt-notificationd")
-    (version "0.17.0")
+    (version "1.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1dyal7brmfnydfgb6lpxnqww8fj5gzixs7s3wf5nn2ihsz1wm4nk"))))
+        (base32 "0bz3qdvv591zvpkxqzqqmh1yq5icc3iinmjr13qzws3ajlj19z44"))))
     (build-system cmake-build-system)
     (inputs
      (list kwindowsystem
@@ -471,24 +471,7 @@ as a whole and are not limited to distinct applications.")
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools-5))
-    (arguments
-     '(#:tests? #f                      ; no test target
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-source
-           (lambda _
-             (substitute* '("autostart/CMakeLists.txt")
-               (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
-                "DESTINATION \"etc/xdg"))
-             #t))
-         (add-after 'unpack 'patch-translations-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* '("config/CMakeLists.txt"
-                            "src/CMakeLists.txt")
-               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
-                (string-append (assoc-ref outputs "out")
-                               "/share/lxqt/translations")))
-             #t)))))
+    (arguments '(#:tests? #f))          ; no test target
     (home-page "https://lxqt-project.org")
     (synopsis "The LXQt notification daemon")
     (description "lxqt-notificationd is LXQt's implementation of a daemon