summary refs log tree commit diff
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2021-06-02 01:11:31 +0200
committerLeo Famulari <leo@famulari.name>2021-06-02 00:54:39 -0400
commit841edfa49119c63eade4930751ac4ff5c012bfe5 (patch)
tree6c89a20be86b98ab74d135e2bed67b69640ba698
parentb94bc3ea30a9451f9019cca66ac20f585870eecd (diff)
downloadguix-841edfa49119c63eade4930751ac4ff5c012bfe5.tar.gz
gnu: redis: Update to 6.2.4 [security fixes].
Fixes CVE-2021-29477.

* gnu/packages/databases.scm (redis): Update to 6.2.4.
[arguments]: Disable the 'integration/failover' test.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/databases.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cead8c0e5a..cd760ee5ef 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -51,6 +51,7 @@
 ;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;; Copyright © 2021 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2135,14 +2136,14 @@ similar to BerkeleyDB, LevelDB, etc.")
 (define-public redis
   (package
     (name "redis")
-    (version "6.0.11")
+    (version "6.2.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.redis.io/releases/redis-"
                                   version".tar.gz"))
               (sha256
                (base32
-                "0prwqap452m581nyc3cz642d1z3x9nd81896hlqdm3z8238z49y9"))
+                "0vp1d9mlfsppry3nsj9f7bmh9wjgsy3jggp24sac1hhgl43c8cms"))
               (modules '((guix build utils)))
               (snippet
                ;; Delete bundled jemalloc, as the package will use the libc one
@@ -2150,8 +2151,8 @@ similar to BerkeleyDB, LevelDB, etc.")
                        #t))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("procps" ,procps) ; for tests
-       ("tcl" ,tcl)))     ; for tests
+     `(("procps" ,procps)               ; for tests
+       ("tcl" ,tcl)))                   ; for tests
     (arguments
      '(#:phases
        (modify-phases %standard-phases
@@ -2168,9 +2169,10 @@ similar to BerkeleyDB, LevelDB, etc.")
            (lambda _
              ;; Disable failing tests
              (substitute* "tests/test_helper.tcl"
-               (("    integration/replication[^-]") "")
-               (("    integration/replication-4") "")
-               (("    integration/replication-psync") ""))
+               (("integration/failover") "")
+               (("integration/replication-4") "")
+               (("integration/replication-psync") "")
+               (("integration/replication[^-]") ""))
              #t)))
        #:make-flags `("CC=gcc"
                       "MALLOC=libc"