summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-20 06:14:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-20 19:49:47 +0100
commit84775d65a8aedcb8308c74d4ac7223f02d8fdd3e (patch)
tree2c1d4b2ae837f407437c3e905475749bd366f517
parentb5df3e266b8db0c2da9f70e317349c90dac30623 (diff)
downloadguix-84775d65a8aedcb8308c74d4ac7223f02d8fdd3e.tar.gz
gnu: leocad: Update phase style.
* gnu/packages/lego.scm (leocad)[arguments]: Substitute INVOKE for
SYSTEM* and end all phases with an explicit #t.
-rw-r--r--gnu/packages/lego.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/lego.scm b/gnu/packages/lego.scm
index 84e740fa17..80df42bb69 100644
--- a/gnu/packages/lego.scm
+++ b/gnu/packages/lego.scm
@@ -84,7 +84,7 @@ restrictions that stem from limitations of the standard RCX firmware.")
                 "189wj221fn08bnsfwy8050bxkjgjwinkn19qdcvb6c2ry2lnfra9"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("qttools" ,qttools)))           ;for lrelease
+     `(("qttools" ,qttools)))           ; for lrelease
     (inputs
      `(("mesa" ,mesa)
        ("qtbase" ,qtbase)
@@ -96,12 +96,13 @@ restrictions that stem from limitations of the standard RCX firmware.")
          (replace 'configure
            (lambda* (#:key outputs inputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "qmake"
-                               (string-append "INSTALL_PREFIX=" out)
-                               ;; Otherwise looks for lrelease-qt4
-                               "QMAKE_LRELEASE=lrelease"
-                               ;; Don't pester users about updates
-                               "DISABLE_UPDATE_CHECK=1")))))
+               (invoke "qmake"
+                       (string-append "INSTALL_PREFIX=" out)
+                       ;; Otherwise looks for lrelease-qt4.
+                       "QMAKE_LRELEASE=lrelease"
+                       ;; Don't pester users about updates.
+                       "DISABLE_UPDATE_CHECK=1")
+               #t)))
          (add-after 'configure 'reset-resource-timestamps
            (lambda _
              ;; The contents of build/release/.qrc/qrc_leocad.cpp generated by
@@ -114,7 +115,8 @@ restrictions that stem from limitations of the standard RCX firmware.")
                                   (src (string-append base ".ts"))
                                   (st (stat src)))
                              (set-file-time file st)))
-                         (find-files "." "leocad_.*\\.qm"))))))))
+                         (find-files "." "leocad_.*\\.qm")))
+             #t)))))
     (home-page "http://www.leocad.org")
     (synopsis "Create virtual Lego models")
     (description