summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-28 15:13:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-28 15:13:39 +0300
commit862a4f3f92922ddda39f82c495d38f4a02e05f51 (patch)
tree72d074497b8b06d3bf033206e8f3a651ad1305f1
parented22def6cc89a9295b44423699303df48ff155f4 (diff)
downloadguix-862a4f3f92922ddda39f82c495d38f4a02e05f51.tar.gz
gnu: Rename rust-unicase-2.6 to rust-unicase-2.
* gnu/packages/crates-io.scm (rust-unicase-2.6): Rename to ...
(rust-unicase-2): ... this.
(rust-unicase-1): Inherit from rust-unicase-2.
(rust-http-req-0.5, rust-phf-shared-0.8, rust-pulldown-cmark-0.4,
rust-rusqlite-0.19)[arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/crates-io.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4cdc5127d8..5b1b8262b9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10164,7 +10164,7 @@ or response body.")
        #:cargo-inputs
        ;; Haven't packaged rustls and webpki because of license
        (("rust-native-tls" ,rust-native-tls-0.2)
-        ("rust-unicase" ,rust-unicase-2.6))))
+        ("rust-unicase" ,rust-unicase-2))))
     (home-page "https://github.com/jayjamesjay/http_req")
     (synopsis
      "HTTP client with built-in HTTPS support")
@@ -16380,7 +16380,7 @@ function data structures.")
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-siphasher" ,rust-siphasher-0.3)
-        ("rust-unicase" ,rust-unicase-2.6))))
+        ("rust-unicase" ,rust-unicase-2))))
     (home-page "https://github.com/sfackler/rust-phf")
     (synopsis "Support code shared by PHF libraries")
     (description
@@ -17653,7 +17653,7 @@ stack pointer and inspect the properties of the stack.")
        (("rust-bitflags" ,rust-bitflags-1)
         ("rust-getopts" ,rust-getopts-0.2)
         ("rust-memchr" ,rust-memchr-2.2)
-        ("rust-unicase" ,rust-unicase-2.6))
+        ("rust-unicase" ,rust-unicase-2))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.2)
         ("rust-html5ever" ,rust-html5ever-0.23)
@@ -19534,7 +19534,7 @@ console applications.")
        (("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-regex" ,rust-regex-1)
         ("rust-tempdir" ,rust-tempdir-0.3)
-        ("rust-unicase" ,rust-unicase-2.6)
+        ("rust-unicase" ,rust-unicase-2)
         ("rust-uuid" ,rust-uuid-0.7))))
     (home-page "https://github.com/rusqlite/rusqlite")
     (synopsis "Wrapper for SQLite")
@@ -25537,7 +25537,7 @@ with the Unicode character database.")
      "Unchecked indexing wrapper using regular index syntax.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-unicase-2.6
+(define-public rust-unicase-2
   (package
     (name "rust-unicase")
     (version "2.6.0")
@@ -25563,7 +25563,7 @@ with the Unicode character database.")
 
 (define-public rust-unicase-1
   (package
-    (inherit rust-unicase-2.6)
+    (inherit rust-unicase-2)
     (name "rust-unicase")
     (version "1.4.2")
     (source