summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-04 21:43:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-05 16:17:26 +0100
commit89cd988b6ce63c2506f6c7faa57523e8b31869b1 (patch)
tree40f0d9e2641a2e756df843ce9c5df8f2bcfa69bb
parentabe2ec735fd8c13985901377ba358e51c57e817c (diff)
downloadguix-89cd988b6ce63c2506f6c7faa57523e8b31869b1.tar.gz
gnu: Add python-snowballstemmer.
* gnu/packages/python.scm (python-snowballstemmer,
  python2-snowballstemmer): New variables.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 04cd3fa905..74ae1e8f5b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11695,6 +11695,30 @@ provide extendible implementations of common aspects of a cloud so that you can
 focus on building massively scalable web applications.")
     (license license:expat)))
 
+(define-public python-snowballstemmer
+  (package
+    (name "python-snowballstemmer")
+    (version "1.2.1")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "snowballstemmer" version))
+      (sha256
+       (base32
+        "0a0idq4y5frv7qsg2x62jd7rd272749xk4x99misf5rcifk2d7wi"))))
+    (build-system python-build-system)
+    (arguments
+     `(;; No tests exist
+       #:tests? #f))
+    (home-page "https://github.com/shibukawa/snowball_py")
+    (synopsis "Snowball stemming library collection for Python")
+    (description "This package provides 16 word stemmer algorithms generated
+from Snowball algorithms.  It includes the 15 original ones plus the Poerter
+English stemmer.")
+    (license license:bsd-3)))
+
+(define-public python2-snowballstemmer
+  (package-with-python2 python-snowballstemmer))
+
 (define-public python-betamax
   (package
     (name "python-betamax")