summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2017-02-16 10:01:34 -0600
committerChristopher Allan Webber <cwebber@dustycloud.org>2017-02-16 15:43:56 -0600
commit8a0c2552b4cf15e5709fd205530f62c007e195aa (patch)
tree83edbe86aea01537a58e47944fc31d34c7c7eeca
parent856b7037aacaef292b2fa48909b6c0c33019b075 (diff)
downloadguix-8a0c2552b4cf15e5709fd205530f62c007e195aa.tar.gz
gnu: Add scheme48-rx.
* gnu/packages/scheme.scm (scheme48-rx): New variable.
-rw-r--r--gnu/packages/scheme.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 1210ab526b..af416c502a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -805,3 +805,42 @@ Using Scheme, a dialect of the Lisp programming language, the book explains
 core computer science concepts such as abstraction in programming,
 metalinguistic abstraction, recursion, interpreters, and modular programming.")
       (license cc-by-sa4.0))))
+
+(define-public scheme48-rx
+  (let* ((commit "d3231ad13de2b44e3ee173b1c9d09ff165e8b6d5")
+         (revision "1"))
+    (package
+      (name "scheme48-rx")
+      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/scheme/rx")
+               (commit commit)))
+         (sha256
+          (base32
+           "1nmziaibgmfi346kzidj6xyad0vm7724qymbzgxvdzyrqji6v6yz"))
+         (file-name (string-append name "-" version "-checkout"))))
+      (build-system trivial-build-system)
+      (arguments
+       `(#:modules ((guix build utils))
+         #:builder
+         (begin
+           (use-modules (guix build utils))
+           (let ((share (string-append %output
+                                       "/share/scheme48-"
+                                       ,(package-version scheme48)
+                                       "/rx")))
+             (chdir (assoc-ref %build-inputs "source"))
+             (mkdir-p share)
+             (copy-recursively "." share)))))
+      (native-inputs
+       `(("source" ,source)
+         ("scheme48" ,scheme48)))
+      (home-page "https://github.com/scheme/rx/")
+      (synopsis "SRE String pattern-matching library for scheme48")
+      (description
+       "String pattern-matching library for scheme48 based on the SRE
+regular-expression notation.")
+      (license bsd-3))))