summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 13:44:16 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:50 +0530
commit8a8b3c3398a86dce0b883f422c1e233b957e00b5 (patch)
treeabef30de9573947249b4c0e6837f68da4143632b
parent9fa58ec9e40f68aed8c5d6ad027ff140f0e1cb7f (diff)
downloadguix-8a8b3c3398a86dce0b883f422c1e233b957e00b5.tar.gz
gnu: Add rust-aes-soft-0.4.
* gnu/packages/crates-io.scm (rust-aes-soft-0.4): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0d024ba761..363560e164 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -194,6 +194,32 @@ the Rust programming language.")
         (sha256
          (base32
           "1rw11hycfjhqbc7z1smn75m0sczq519msjwimxh7b8s6n4pzk5r7"))))
+(define-public rust-aes-soft-0.4
+  (package
+    (name "rust-aes-soft")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aes-soft" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "19szsg0qqxq42k7bj5p3svb147n8wxy9a20n4g7mcl2fwrz689a9"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-block-cipher" ,rust-block-cipher-0.7)
+        ("rust-byteorder" ,rust-byteorder-1)
+        ("rust-opaque-debug" ,rust-opaque-debug-0.2))
+       #:cargo-development-inputs
+       (("rust-block-cipher" ,rust-block-cipher-0.7))))
+    (home-page "https://github.com/RustCrypto/block-ciphers")
+    (synopsis "Bit-sliced implementation of AES (Rijndael) block ciphers")
+    (description "This package provides a bit-sliced implementation of
+AES (Rijndael) block ciphers.")
+    (license (list license:expat license:asl2.0))))
+
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t