summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-03-29 17:59:47 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-04-05 16:10:06 +0200
commit8b578c217f57ce009dbbc9df1036a06b6b822754 (patch)
tree080c68f8895b38e2639fa14a615156ce8d928538
parente29b1fff1d8147623ab149fca7b0cc42a376bf62 (diff)
downloadguix-8b578c217f57ce009dbbc9df1036a06b6b822754.tar.gz
gnu: crypto++: Update to 8.5.0.
* gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
[origin]: Use git-fetch and git-reference.
-rw-r--r--gnu/packages/crypto.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 94f9cbeebf..57d417de80 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -773,15 +773,18 @@ data on your platform, so the seed itself will be as random as possible.
 (define-public crypto++
   (package
     (name "crypto++")
-    (version "8.4.0")
+    (version "8.5.0")
     (source (origin
-              (method url-fetch/zipbomb)
-              (uri (string-append "https://cryptopp.com/cryptopp"
-                                  (string-join (string-split version #\.) "")
-                                  ".zip"))
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/weidai11/cryptopp")
+                (commit
+                 (string-append "CRYPTOPP_"
+                                (string-replace-substring version "." "_")))))
               (sha256
                (base32
-                "16kvfm11xv7j9a3yykzysjgw38a9b7lnc5n5x5h82g395k6ybxf0"))))
+                "0in7rlazq91vfi519g9wr7bh87hii47cimxv7fmj0f88vhjaidq3"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags