summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-01 11:43:33 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-01 11:55:09 +0200
commit8e5e8724d26033fabe207cfea05b26bcab8c1c99 (patch)
tree6d7e9b2b6aa5cc9470b0c58a7ba75b1605287c22
parentd31860b9de07810e114490db5cc160a8b078c58d (diff)
downloadguix-8e5e8724d26033fabe207cfea05b26bcab8c1c99.tar.gz
gnu: make-boot0: Use 'modify-phases'.
* gnu/packages/commencement.scm (gnu-make-boot0)[arguments]: Use
'modify-phases'.
-rw-r--r--gnu/packages/commencement.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 700de685a7..976b0ac87d 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -75,17 +75,17 @@
         #:tests? #f                  ; cannot run "make check"
         ,@(substitute-keyword-arguments (package-arguments gnu-make)
             ((#:phases phases)
-             `(alist-replace
-               'build (lambda _
-                        (zero? (system* "./build.sh")))
-               (alist-replace
-                'install (lambda* (#:key outputs #:allow-other-keys)
-                           (let* ((out (assoc-ref outputs "out"))
-                                  (bin (string-append out "/bin")))
-                             (mkdir-p bin)
-                             (copy-file "make"
-                                        (string-append bin "/make"))))
-                ,phases))))))
+             `(modify-phases ,phases
+                (replace 'build
+                  (lambda _
+                    (zero? (system* "./build.sh"))))
+                (replace 'install
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (bin (string-append out "/bin")))
+                      (mkdir-p bin)
+                      (copy-file "make"
+                                 (string-append bin "/make"))))))))))
      (native-inputs '())                          ; no need for 'pkg-config'
      (inputs %bootstrap-inputs))))