summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 19:23:28 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commit8ea8e8d3c332d2b187c26762c8e9e7930f6c2cb7 (patch)
tree1d8437df4bf02178034bd3773bdedf16e0fa3fea
parent934c5d5b28f74ab2fe187ad727e4b56cfda6def8 (diff)
downloadguix-8ea8e8d3c332d2b187c26762c8e9e7930f6c2cb7.tar.gz
guix: python-build-system: Change pypi-uri to use https://pypi.io.
* guix/build-system/python.scm (pypi-uri): Use https://pypi.io.
* gnu/packages/python.scm (python-twisted)[uri]: Remove https://pypi.io.
-rw-r--r--gnu/packages/python.scm5
-rw-r--r--guix/build-system/python.scm2
2 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4567a91e51..8c34ff2e46 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9097,10 +9097,7 @@ to provide a high-level synchronous API on top of the libev event loop.")
     (version "16.2.0")
     (source (origin
               (method url-fetch)
-              (uri (list (pypi-uri "Twisted" version ".tar.bz2") ; 404
-                         (string-append
-                          "https://pypi.io/packages/source/T/Twisted/"
-                          "Twisted-" version ".tar.bz2")))
+              (uri (pypi-uri "Twisted" version ".tar.bz2"))
               (sha256
                (base32
                 "0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index c3d6c62404..705943eb73 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -48,7 +48,7 @@
   "Return a URI string for the Python package hosted on the Python Package
 Index (PyPI) corresponding to NAME and VERSION.  EXTENSION is the file name
 extension, such as '.tar.gz'."
-  (string-append "https://pypi.python.org/packages/source/"
+  (string-append "https://pypi.io/packages/source/"
                  (string-take name 1) "/" name "/"
                  name "-" version extension))