summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-04-28 20:53:15 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-04-28 20:53:15 +0800
commit9271dfddc9989e0c27b5bff050e998af09a59b79 (patch)
treeabc83a3f4e6fddaaad020efd4abd76f36f629c27
parentc3c031621517444beb26c8e3a84a6621049c1731 (diff)
downloadguix-9271dfddc9989e0c27b5bff050e998af09a59b79.tar.gz
gnu: python-libvirt: Update to 3.2.0.
* gnu/packages/qemu.scm (python-libvirt, python2-libvirt): Update to 3.2.0.
-rw-r--r--gnu/packages/qemu.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 652836a9a8..d86447b3ea 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -381,13 +381,13 @@ three libraries:
 (define-public python-libvirt
   (package
     (name "python-libvirt")
-    (version "2.0.0")
+    (version "3.2.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "libvirt-python" version))
               (sha256
                (base32
-                "0h0x5lpsx97bvw20pzfcsdmmivximddq4qmn8fk0n55dqv0wn5kq"))))
+                "0g80vhjss1a48w60zw0pd5fhpwfjw2dqhh0fbs730brkxj6xv1dc"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -395,9 +395,10 @@ three libraries:
          (add-after 'unpack 'patch-nosetests-path
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "setup.py"
-               (("sys.executable, \"/usr/bin/nosetests\"")
-                (string-append "\"" (which "bash") "\", \""
-                               (which "nosetests") "\"")))
+               (("\"/usr/bin/nosetests\"")
+                (string-append "\"" (which "nosetests") "\""))
+               (("self\\.spawn\\(\\[sys\\.executable, nose\\]\\)")
+                (format #f "self.spawn([\"~a\", nose])" (which "bash"))))
              #t)))))
     (inputs
      `(("libvirt" ,libvirt)))