summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-02-28 14:24:52 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-03-02 17:31:40 -0500
commit927ff2c379bbab184a7b783d5cec91e53ceaa7e2 (patch)
tree5098a8994dea8ce0b940cd1bde113272ba9532ac
parent993300f6ccfbc9cbe628978690fc98eb63365dbd (diff)
downloadguix-927ff2c379bbab184a7b783d5cec91e53ceaa7e2.tar.gz
gnu: Add mpdscribble.
* gnu/packages/mpd.scm (mpdscribble): New variable.
-rw-r--r--gnu/packages/mpd.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 2d7ca6ef37..034059acff 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2014, 2015 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
@@ -211,3 +211,27 @@ for library searches, extended song format, items filtering, the ability to
 sort playlists, and a local filesystem browser.")
     (home-page "http://ncmpcpp.rybczak.net/")
     (license license:gpl2+)))
+
+(define-public mpdscribble
+  (package
+    (name "mpdscribble")
+    (version "0.22")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.musicpd.org/download/mpdscribble/"
+                                  version "/mpdscribble-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0f0ybx380x2z2g1qvdndpvcrhkrgsfqckhz3ryydq2w3pl12v27z"))))
+    (build-system gnu-build-system)
+    (inputs `(("libmpdclient" ,libmpdclient)
+              ("curl" ,curl)
+              ("glib" ,glib)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (synopsis "MPD client for track scrobbling")
+    (description "mpdscribble is a Music Player Daemon client which submits
+information about tracks being played to a scrobbler, such as Libre.FM.")
+    ;; musicpd.org doesn't mention mpdscribble.  It points users to this wiki
+    ;; instead.
+    (home-page "http://mpd.wikia.com/wiki/Client:Mpdscribble")
+    (license license:gpl2+)))