summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-07-03 10:57:50 +0200
committerRutger Helling <rhelling@mykolab.com>2018-07-03 11:01:21 +0200
commit940c2c5c14745b9559f83fca07db74aaa3f14c5e (patch)
tree894a0bccca407928b0ee8e978dccfda3bb8d9800
parentfab8d41c647c42d75779bbe601c5b4c64283a806 (diff)
downloadguix-940c2c5c14745b9559f83fca07db74aaa3f14c5e.tar.gz
gnu: openrct2: Update to 0.2.0.
* gnu/packages/games.scm (openrct2): Update to 0.2.0.
[configure-flags]: Add -DDOWNLOAD_OBJECTS=OFF configure flag.
[arguments]: Add 'fixgcc7, 'get-rid-of-errors phases.
[native-inputs]: Add gcc@7.
-rw-r--r--gnu/packages/games.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 96b45b9e8d..8e0dfcb8ff 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -75,6 +75,7 @@
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages game-development)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gimp)
@@ -2321,7 +2322,7 @@ Transport Tycoon Deluxe.")
 (define-public openrct2
   (package
     (name "openrct2")
-    (version "0.1.1")
+    (version "0.2.0")
     (source
      (origin
        (method url-fetch)
@@ -2329,11 +2330,12 @@ Transport Tycoon Deluxe.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "1bahkzlf9k92cc4zs4nk4wy59323kiw8d3wm0vjps3kp7iznqyjx"))
+         "1yrbjra27n2xxb1x47v962lc3qi8gwm5ws4f97952nvn533zrwxz"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-DDOWNLOAD_TITLE_SEQUENCES=OFF")
+     `(#:configure-flags (list "-DDOWNLOAD_OBJECTS=OFF"
+                               "-DDOWNLOAD_TITLE_SEQUENCES=OFF")
        #:tests? #f ; Tests require network.
        #:phases
         (modify-phases %standard-phases
@@ -2342,14 +2344,23 @@ Transport Tycoon Deluxe.")
               (let ((titles (assoc-ref inputs "openrct2-title-sequences"))
                     (objects (assoc-ref inputs "openrct2-objects")))
               ;; Fix some references to /usr/share.
-              ;; Change to Platform.Linux.cpp on 0.1.2+
-              (substitute* "src/openrct2/platform/linux.c"
+              (substitute* "src/openrct2/platform/Platform.Linux.cpp"
                 (("/usr/share")
                  (string-append (assoc-ref %outputs "out") "/share")))
               (copy-recursively (string-append titles
                                 "/share/openrct2/title-sequences") "data/title")
               (copy-recursively (string-append objects
-                                "/share/openrct2/objects") "data/object")))))))
+                                "/share/openrct2/objects") "data/object"))))
+          (add-before 'configure 'fixgcc7
+             (lambda _
+               (unsetenv "C_INCLUDE_PATH")
+               (unsetenv "CPLUS_INCLUDE_PATH")
+               #t))
+          (add-after 'fixgcc7 'get-rid-of-errors
+            (lambda _
+              ;; Don't treat warnings as errors.
+              (substitute* "CMakeLists.txt"
+                (("-Werror") "")))))))
     (inputs `(("curl" ,curl)
               ("fontconfig" ,fontconfig)
               ("freetype" ,freetype)
@@ -2365,7 +2376,8 @@ Transport Tycoon Deluxe.")
               ("speexdsp" ,speexdsp)
               ("zlib" ,zlib)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("gcc" ,gcc-7)
+       ("pkg-config" ,pkg-config)))
     (home-page "https://github.com/OpenRCT2/OpenRCT2")
     (synopsis "Free software re-implementation of RollerCoaster Tycoon 2")
     (description "OpenRCT2 is a free software re-implementation of