summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-03 23:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-03 23:12:20 +0200
commit94c4a58a0acb7af0baf7301c39850d633390c4bc (patch)
tree869abd3e3459aee4dcf69b4c909e40dabbb01182
parentaeb7ec5c9a67c9936b5d01d6e933cf4c282058d2 (diff)
downloadguix-94c4a58a0acb7af0baf7301c39850d633390c4bc.tar.gz
gnu: Add Netcat.
* gnu/packages/system.scm (netcat): New variable.
-rw-r--r--gnu/packages/system.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 3524544746..3115714b08 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -314,3 +314,26 @@ files, which contain information about the IANA-assigned port, protocol, and
 ONC RPC numbers")
     (home-page "http://packages.debian.org/sid/netbase")
     (license gpl2)))
+
+(define-public netcat
+  (package
+    (name "netcat")
+    (version "0.7.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/netcat/netcat-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "1frjcdkhkpzk0f84hx6hmw5l0ynpmji8vcbaxg8h5k2svyxz0nmm"))))
+    (build-system gnu-build-system)
+    (home-page "http://netcat.sourceforge.net")
+    (synopsis "Read and write data over TCP/IP")
+    (description
+     "Netcat is a featured networking utility which reads and writes data
+across network connections, using the TCP/IP protocol.  It is designed to be a
+reliable \"back-end\" tool that can be used directly or easily driven by other
+programs and scripts. At the same time, it is a feature-rich network debugging
+and exploration tool, since it can create almost any kind of connection you
+would need and has several interesting built-in capabilities.")
+    (license gpl2+)))