summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 19:55:57 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:22 +0100
commit962b288ad5c117dfd924b38f808b50a6faf59dbf (patch)
tree20087d2bf58d824813a9ce226b20f1d3f5c2f71f
parent7cfb118cbe77cc9d351b9ad42d0cde93ba29be31 (diff)
downloadguix-962b288ad5c117dfd924b38f808b50a6faf59dbf.tar.gz
gnu: Add kmbox.
* gnu/packages/kde-pim.scm (kmbox): New variable.
-rw-r--r--gnu/packages/kde-pim.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 393ffaba7e..be05abe386 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -111,6 +111,29 @@ This package contains the Akonadi PIM storage server and associated
 programs.")
     (license license:fdl1.2+)))
 
+(define-public kmbox
+  (package
+    (name "kmbox")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/kmbox-" version ".tar.xz"))
+       (sha256
+        (base32 "13b5v1nx46k5ais3cms7yxrfi8p6xbljpkpg3f7v1asb6kshv7g2"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kcodecs" ,kcodecs)
+       ("kmime" ,kmime)
+       ("qtbase" ,qtbase)))
+    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+    (synopsis "Library for handling mbox mailboxes")
+    (description "A library for accessing mail storages in MBox format.")
+    (license license:lgpl2.0+ )))
+
 (define-public kmime
   (package
     (name "kmime")