summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Howard <christopher@librehacker.com>2020-04-18 23:31:04 -0800
committerChristopher Baines <mail@cbaines.net>2020-12-18 14:52:53 +0000
commit98ff729e62cd9652c7106f3ff311cc30bf2a7dac (patch)
tree420c3f745aa80888f44aca33852b0e4458db4472
parent45c5851872d9ce6ca992be28d3e34e35e01d958a (diff)
downloadguix-98ff729e62cd9652c7106f3ff311cc30bf2a7dac.tar.gz
gnu: Add libticonv.
* gnu/packages/emulators.scm (libticonv): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/emulators.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index e34679fcea..55d8efff4e 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1424,6 +1424,46 @@ This is a part of the TiLP project.")
     (home-page "http://lpg.ticalc.org/prj_tilp/")
     (license license:gpl2+)))
 
+(define-public libticonv
+  (package
+    (name "libticonv")
+    (version "1.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri "https://www.ticalc.org/pub/unix/tilibs.tar.gz")
+              (sha256
+               (base32
+                "07cfwwlidgx4fx88whnlch6y1342x16h15lkvkkdlp2y26sn2yxg"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; build fails with out --enable-iconv (...?)
+     `(#:configure-flags (list "--enable-iconv")
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'unpack
+           (lambda* (#:key source #:allow-other-keys)
+             (invoke "tar" "xvkf" source)
+             (invoke "tar" "xvkf"
+                     (string-append "tilibs2/libticonv-"
+                                    ,version ".tar.bz2"))
+             (chdir (string-append "libticonv-" ,version))
+             #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("glib" ,glib)))
+    (synopsis "Character conversion library for TI calculators")
+    (description
+     "This package contains libticonv, a library to support working with
+@acronym{TI, Texas Instruments} calculator charsets.
+
+This is a part of the TiLP project.")
+    (home-page "http://lpg.ticalc.org/prj_tilp/")
+    (license license:gpl2+)))
+
 (define-public mame
   (package
     (name "mame")