summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 12:59:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:03:07 +0200
commit9ae40d6b92a355f530cf05c15d03926bb9f1dbca (patch)
tree12c77c0ff9a7cc3036c15a644ae88025be266581
parentad39b6d88f42249facd1ea09ca30c3ead641def0 (diff)
downloadguix-9ae40d6b92a355f530cf05c15d03926bb9f1dbca.tar.gz
gnu: Add texlive-algobox.
* gnu/packages/tex.scm (texlive-algobox): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ce5045215e..e82c61b5de 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1269,6 +1269,29 @@ together with a header, a caption, etc.  @code{\\listofalgorithms} is
 defined.")
     (license license:lppl)))
 
+(define-public texlive-algobox
+  (package
+    (name "texlive-algobox")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/algobox/" "source/latex/algobox/"
+                   "tex/latex/algobox/")
+             (base32
+              "03z5s4v1asfp6rm51wfkmax69rlggfdyb3p1acdy8cx1gwd10f2w")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/algobox")
+    (synopsis "Typeset Algobox programs")
+    (description
+     "This LaTeX package can typeset Algobox programs almost exactly as
+displayed when editing with Algobox itself, using an input syntax very similar
+to the actual Algobox program text.  It gives better results than Algobox's
+own LaTeX export which does not look like the editor rendition, produces
+standalone documents cumbersome to customize, and has arbitrary and
+inconsistent differences between the input syntax and the program text.")
+    (license license:gpl3+)))
+
 (define-public texlive-apnum
   (package
     (name "texlive-apnum")