summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 18:51:23 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-06 21:54:01 +0300
commita2221c75119e568d41d4c4f8191546a986ba9cda (patch)
tree6d91e07e1db748a9c9be17f0e6810ff007c40352
parenta5dbc07d38d3ae1a66a478efb959f74cce93b51f (diff)
downloadguix-a2221c75119e568d41d4c4f8191546a986ba9cda.tar.gz
gnu: Add rust-peg-runtime-0.6.
* gnu/packages/crates-io.scm (rust-peg-runtime-0.6): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 15a29e0961..a5c797f88c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -15906,6 +15906,27 @@ the @code{take_while} predicate returned false after dropping the @code{by_ref}.
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-peg-runtime-0.6
+  (package
+    (name "rust-peg-runtime")
+    (version "0.6.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "peg-runtime" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0r583cq923v0narrpq73qmp780yg4pablzklhrwnr64xwsbjh6hc"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/kevinmehall/rust-peg")
+    (synopsis "Runtime support for rust-peg grammars")
+    (description
+     "PEG provides a Parsing Expression Grammar.  This package provides
+runtime support for rust-peg grammars.  To use rust-peg, see the peg crate.")
+    (license license:expat)))
+
 (define-public rust-percent-encoding-2.1
   (package
     (name "rust-percent-encoding")