summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-06-14 23:28:58 +0200
committerAndreas Enge <andreas@enge.fr>2013-06-14 23:28:58 +0200
commita2609b41b9167a648d0c9c0a01320c7cb5ebe8e1 (patch)
treee37ef47c2bca98f1297e578b7e728cf719ee8f9e
parent6131c43d45e2765345d51d355c4e9136f2603747 (diff)
downloadguix-a2609b41b9167a648d0c9c0a01320c7cb5ebe8e1.tar.gz
gnu: Add harfbuzz.
* gnu/packages/gtk.scm (harfbuzz): New variable.
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7a0724fbf3..64f9512715 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -26,6 +26,7 @@
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages icu4c)
   #:use-module (gnu packages libpng)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
@@ -103,3 +104,27 @@ antialiased text rendering. All drawing operations can be transformed by any
 affine transformation (scale, rotation, shear, etc.)")
    (license license:lgpl2.1) ; or Mozilla Public License 1.1
    (home-page "http://cairographics.org/")))
+
+(define-public harfbuzz
+  (package
+   (name "harfbuzz")
+   (version "0.9.18")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-"
+                                version ".tar.bz2"))
+            (sha256
+             (base32
+              "026rlwspf1zn5akds9fwibpqpn47kmlnmqm5fi0cp4k4dnygpw7y"))))
+   (build-system gnu-build-system)
+   (inputs
+    `(("cairo" ,cairo)
+      ("icu4c" ,icu4c)
+      ("pkg-config" ,pkg-config)
+      ("python" ,python)))
+   (synopsis "opentype text shaping engine")
+   (description
+    "HarfBuzz is an OpenType text shaping engine.")
+   (license (license:x11-style "file://COPYING"
+                       "See 'COPYING' in the distribution."))
+   (home-page "http://www.freedesktop.org/wiki/Software/HarfBuzz/")))