summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-08 10:48:25 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-10 17:23:32 +0200
commita38f03e4deaccf79660c1b06b49f8f18bc0096d5 (patch)
treef46cff835f37666aff66084d66b8832d7e3b76e7
parentf0114656876dcf2e09874e4ea0c00cacf31f1bb2 (diff)
downloadguix-a38f03e4deaccf79660c1b06b49f8f18bc0096d5.tar.gz
gnu: Add mpdevil.
* gnu/packages/mpd.scm (mpdevil): New variable.
-rw-r--r--gnu/packages/mpd.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 046471f32d..05737f3a86 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -43,6 +43,7 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages build-tools) ;meson-next
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cdrom)
@@ -523,3 +524,37 @@ for your favorite MPD client but an addition to get a better
 album-experience.")
     (home-page "https://gitlab.com/coderkun/mcg")
     (license license:gpl3+)))
+
+(define-public mpdevil
+  (package
+    (name "mpdevil")
+    (version "1.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/SoongNoonien/mpdevil")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1va8fqlz8qb68gvacnzmp4asnipi11316n1cv2wb41sml9d7v00j"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+            (lambda _
+              (let ((prog (string-append #$output "/bin/mpdevil")))
+                (wrap-program prog
+                  `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+                  `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
+    (inputs (list bash-minimal gtk+ python python-mpd2 python-pygobject))
+    (native-inputs (list `(,glib "bin")))
+    (home-page "https://github.com/SoongNoonien/mpdevil")
+    (synopsis "Music browser for the MPD")
+    (description "mpdevil is a music browser for the Music Player Daemon (MPD),
+which is focused on playing local music without the need of managing playlists.
+Instead of maintaining a client side database of your music library,
+mpdevil loads all tags and covers on demand.")
+    (license license:gpl3+)))