summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commita4706eef32d6d79dd3f9b2b457410c06e4f63633 (patch)
tree865b311498c7b2832b71d4b8ff7d2bd1789ec603
parent575642f01452df93a44733304254a96a036b3365 (diff)
downloadguix-a4706eef32d6d79dd3f9b2b457410c06e4f63633.tar.gz
gnu: Add ghc-hookup.
* gnu/packages/haskell-xyz.scm (ghc-hookup): New public variable.
-rw-r--r--gnu/packages/haskell-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5cc72bacb3..7d01da6739 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5393,6 +5393,35 @@ interface for statistics based on hmatrix and GSL.")
 functions for Haskell.")
     (license license:gpl3+)))
 
+(define-public ghc-hookup
+  (package
+    (name "ghc-hookup")
+    (version "0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "hookup" version))
+       (sha256
+        (base32 "02prkwj4rj8g330z17bpjh7hpwfdvasaxsk74mcvbi03gjpydrib"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision ("1"
+                         "1x4hxcb81rczpywcda3s9jbh2gs1sfwvd7wzv3cxxkbd4smlrh1r")))
+    (inputs
+     (list ghc-async
+           ghc-network
+           ghc-attoparsec
+           ghc-hsopenssl
+           ghc-hsopenssl-x509-system))
+    (properties '((upstream-name . "hookup")))
+    (home-page "https://github.com/glguy/irc-core")
+    (synopsis "Abstracts network connections over SOCKS5 and TLS")
+    (description
+     "This package provides an abstraction for communicating with line-oriented
+network services while abstracting over the use of SOCKS5 and TLS (via
+OpenSSL)")
+    (license license:isc)))
+
 (define-public ghc-hostname
   (package
     (name "ghc-hostname")