summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:20:35 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:23:00 -0500
commita4af21ca6dfc362e15824674c5652bdf1c922ffd (patch)
tree44a604b8a274f72db832429b30c898930734e577
parentc0aacfa5b903f1a0b9038aee7fe8f7f120f9d734 (diff)
downloadguix-a4af21ca6dfc362e15824674c5652bdf1c922ffd.tar.gz
gnu: Add python-tox.
* gnu/packages/python.scm (python-tox): New variable.
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 52950141f2..6be651195d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7322,3 +7322,37 @@ Pytest but stripped of Pytest specific details.")
 
 (define-public python2-pluggy
   (package-with-python2 python-pluggy))
+
+(define-public python-tox
+  (package
+   (name "python-tox")
+   (version "2.3.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "tox" version))
+     (sha256
+      (base32
+       "1vj73ar4rimq3fwy5r2z3jv4g9qbh8rmpmncsc00g0k310acqzxz"))))
+   (build-system python-build-system)
+   (arguments
+    ;; FIXME: Tests require a newer version of pytest, but upgrading our
+    ;; pytest breaks other packages.
+    '(#:tests? #f))
+   (inputs
+    `(("python-setuptools" ,python-setuptools)
+      ("python-pluggy" ,python-pluggy)
+      ("python-py" ,python-py)
+      ("python-virtualenv" ,python-virtualenv)
+      ("python-pytest" ,python-pytest)))
+   (home-page "http://tox.testrun.org/")
+   (synopsis "Virtualenv-based automation of test activities")
+   (description "Tox is a generic virtualenv management and test command line
+tool.  It can be used to check that a package installs correctly with
+different Python versions and interpreters, or run tests in each type of
+supported environment, or act as a frontend to continuous integration
+servers.")
+   (license license:expat)))
+
+(define-public python2-tox
+  (package-with-python2 python-tox))