summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-03 13:28:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-01 14:06:03 +0200
commita4e6356e110bb2cd3ad90d8943fd6a700de97ca8 (patch)
tree540c939cdbfbc95358f2937a7a9eca0f770a827d
parent26af1c8d13dfc08f6b703dbd3d6add95ffb1d220 (diff)
downloadguix-a4e6356e110bb2cd3ad90d8943fd6a700de97ca8.tar.gz
gnu: Add trio.
* gnu/packages/code.scm (trio): New variable.
-rw-r--r--gnu/packages/code.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 64df95ded6..63a9280708 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -229,6 +229,29 @@ files, but compared to grep is much faster and respects files like .gitignore,
 .hgignore, etc.")
     (license license:asl2.0)))
 
+(define-public trio
+  (package
+    (name "trio")
+    (version "1.16")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/ctrio/trio/trio-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "02pwd5m5vq7hbrffgm2na1dfc249z50yyr5jv73vdw15bd7ygl44"))))
+    (build-system gnu-build-system)
+    (home-page "http://daniel.haxx.se/projects/trio/")
+    (synopsis "Portable and extendable printf and string functions")
+    (description
+     "Trio is a set of @code{printf} and string functions designed be used by
+applications with a focus on portability or with the need for additional
+features that are not supported by the standard @code{stdio} implementation.")
+    ;; This license is very similar to the ISC license, but the wording is
+    ;; slightly different.
+    (license (license:non-copyleft
+              "http://sourceforge.net/p/ctrio/git/ci/master/tree/README"))))
+
 (define-public withershins
   (package
     (name "withershins")