summary refs log tree commit diff
diff options
context:
space:
mode:
authorRemco van 't Veer <remco@remworks.net>2022-06-29 17:54:00 +0200
committerMarius Bakke <marius@gnu.org>2022-08-29 16:55:30 +0200
commita500e1a061d82b3812d98a186c1fbb86390ba7a6 (patch)
tree2006b750fb89652191a082a837870debb96164bf
parent8ab712526598ac5d485a08c02e6b16faced3df84 (diff)
downloadguix-a500e1a061d82b3812d98a186c1fbb86390ba7a6.tar.gz
gnu: ruby: Update to 2.6.10 [security fixes].
Includes fixes for: CVE-2022-28739, CVE-2021-41819, CVE-2021-41817,
CVE-2021-31810, CVE-2021-32066, CVE-2021-28965, CVE-2020-25613, and
CVE-2020-10933.

* gnu/packages/ruby.scm (ruby-2.6): Update to 2.6.10.

Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/ruby.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a30777ce01..ea025a18c3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -29,6 +29,7 @@
 ;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
 ;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
 ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -100,7 +101,7 @@
 (define-public ruby-2.6
   (package
     (name "ruby")
-    (version "2.6.5")
+    (version "2.6.10")
     (source
      (origin
        (method url-fetch)
@@ -109,7 +110,7 @@
                            "/ruby-" version ".tar.xz"))
        (sha256
         (base32
-         "0qhsw2mr04f3lqinkh557msr35pb5rdaqy4vdxcj91flgxqxmmnm"))
+         "1wn12klc44hn2nh5v1lkqbdyvljip6qhwjqvkkf8zf112gaxxn2z"))
        (modules '((guix build utils)))
        (snippet `(begin
                    ;; Remove bundled libffi