summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:58:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:35 +0200
commita64e00b6940bd6d872ba50b1f9f0ebade1015f52 (patch)
treec5fe4a11fcc5ac1d39286d3a5eb25ef0d5a2dff7
parent24455759cdc7e03c655d13090b627eee489d4661 (diff)
downloadguix-a64e00b6940bd6d872ba50b1f9f0ebade1015f52.tar.gz
gnu: Add texlive-thermodynamics.
* gnu/packages/tex.scm (texlive-thermodynamics): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e770d12a34..7f668d3252 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6740,6 +6740,32 @@ symbols.")
 membrane protein topology plots and helical wheels.")
     (license license:gpl3+)))
 
+(define-public texlive-thermodynamics
+  (package
+    (name "texlive-thermodynamics")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/thermodynamics/"
+                   "source/latex/thermodynamics/"
+                   "tex/latex/thermodynamics/")
+             (base32
+              "0shhwyhwrrkclbacqajgr5gk331pypnmn6pladkfmw87l5p4c5dh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/thermodynamics")
+    (synopsis "Macros for multicomponent thermodynamics documents")
+    (description
+     "This package makes typesetting quantities found in thermodynamics texts
+relatively simple.  The commands are flexible and intended to be relatively
+intuitive.  It handles several sets of notation for total, specific, and molar
+quantities; allows changes between symbols (e.g., @samp{A} vs. @samp{F} for
+Helmholtz free energy); and greatly simplifies the typesetting of symbols and
+partial derivatives commonly encountered in mixture thermodynamics.  Changes
+of one's notes from one textbook to another can be achieved relatively easily
+by changing package options.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")