summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-30 12:36:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-30 12:36:54 +0200
commita6cffe6ec4f168138a2deb929737ee06376cff5c (patch)
treeb6d826bf50fe74f29bb1a4d3925b394decb0e607
parent4347662539721cdb89b6ccbef71bf8fe91b67695 (diff)
downloadguix-a6cffe6ec4f168138a2deb929737ee06376cff5c.tar.gz
gnu: ruby-puma: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-puma)[source]: Download using git-fetch.
[home-page]: Use https.
-rw-r--r--gnu/packages/ruby.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 482be70381..6203352687 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7054,14 +7054,15 @@ part of the Prawn PDF generator.")
     (version "3.9.1")
     (source
      (origin
-       (method url-fetch)
+       (method git-fetch)
        ;; Fetch from GitHub because distributed gem does not contain tests.
-       (uri (string-append "https://github.com/puma/puma/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (uri (git-reference
+              (url "https://github.com/puma/puma")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "03pifga841h17brh4vgia8i2ybh3cmsyg0dbybzdf6dq51wzcxdx"))))
+         "1kj75k81iik3aj73pkc9ixj9rwf95ipkyma65n28m64dgw02qi1f"))))
     (build-system ruby-build-system)
     (arguments
      `(#:tests? #f ; Tests require an out-dated version of minitest.
@@ -7079,7 +7080,7 @@ for Ruby/Rack applications.  Puma is intended for use in both development and
 production environments.  In order to get the best throughput, it is highly
 recommended that you use a Ruby implementation with real threads like Rubinius
 or JRuby.")
-    (home-page "http://puma.io")
+    (home-page "https://puma.io/")
     (license license:expat)))
 
 (define-public ruby-hoe-git