summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-08 23:20:07 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-03 00:04:29 +0200
commitab7f51fa344c757fd2825ce1fff7d6c587d1b609 (patch)
tree42194bc9d832d6ae616c99d9b169fec40630de3f
parent76dd04be470ae3d9e6bca35f8d77449fb282216c (diff)
downloadguix-ab7f51fa344c757fd2825ce1fff7d6c587d1b609.tar.gz
gnu: Add python-pydiff.
* gnu/packages/python.scm (python-pydiff, python2-pydiff): New variables.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 77c4a8347d..35a2cec798 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16301,3 +16301,25 @@ Templates.")
 
 (define-public python2-uritemplate
   (package-with-python2 python-uritemplate))
+
+(define-public python-pydiff
+  (package
+    (name "python-pydiff")
+    (version "0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pydiff" version))
+        (sha256
+          (base32
+            "1als83h9w0gab24ipyna6khm390qmpnpkc5jksmdbs2xc8hp2z44"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/myint/pydiff")
+    (synopsis "Library to diff two Python files at the bytecode level")
+    (description
+      "@code{pydiff} makes it easy to look for actual code changes while
+ignoring formatting changes.")
+    (license license:expat)))
+
+(define-public python2-pydiff
+  (package-with-python2 python-pydiff))