summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 09:26:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:18 +0100
commitace73a93cdb70e2d470387516f22465d170c2d14 (patch)
tree8840bc165e94cd43cc5f9c466c33c437dcd84dce
parenta48d6acc23f426ca70e190e717a20cdb21df297f (diff)
downloadguix-ace73a93cdb70e2d470387516f22465d170c2d14.tar.gz
gnu: coq-gappa: Use INVOKE.
* gnu/packages/coq.scm (coq-gappa)[arguments]: Unconditionally return #T from
build phases by using INVOKE.
-rw-r--r--gnu/packages/coq.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 97ed33d1ba..2d603f91d5 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -254,16 +254,14 @@ inside Coq.")
          (add-before 'configure 'fix-remake
            (lambda _
              (substitute* "remake.cpp"
-               (("/bin/sh") (which "sh")))))
+               (("/bin/sh") (which "sh")))
+             #t))
          (replace 'build
-           (lambda _
-             (zero? (system* "./remake"))))
+           (lambda _ (invoke "./remake")))
          (replace 'check
-           (lambda _
-             (zero? (system* "./remake" "check"))))
+           (lambda _ (invoke "./remake" "check")))
          (replace 'install
-           (lambda _
-             (zero? (system* "./remake" "install")))))))
+           (lambda _ (invoke "./remake" "install"))))))
     (home-page "http://gappa.gforge.inria.fr/")
     (synopsis "Verify and formally prove properties on numerical programs")
     (description "Gappa is a tool intended to help verifying and formally proving