summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:34:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:36 +0200
commitafaf65255d40e0294f6a16c0abc9c431bf575dfc (patch)
tree69518723032d479d61ca4b57fa569f0d060b56bc
parent25f683b55d1373cf5299c34c7ba5d780ca50b807 (diff)
downloadguix-afaf65255d40e0294f6a16c0abc9c431bf575dfc.tar.gz
gnu: Add texlive-moreverb.
* gnu/packages/tex.scm (texlive-moreverb): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 882fc2e93e..5741f32abd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8359,6 +8359,30 @@ a division operation without destroying the values of the counters containing
 the dividend and divisor.")
     (license license:lppl1.3c)))
 
+(define-public texlive-moreverb
+  (package
+    (name "texlive-moreverb")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/moreverb/" "source/latex/moreverb/"
+                   "tex/latex/moreverb/")
+             (base32
+              "0kba3df9cfiz168hsxhwg3a838p3vrgfp42fmwafsf3xq3q2z5hg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/moreverb")
+    (synopsis "Extended verbatim")
+    (description
+     "This package provides a collection of verbatim facilities that provide
+line-numbered verbatim, verbatim that obeys TAB characters, verbatim input and
+verbatim output to file.  The package makes use of the @code{verbatim}
+package.  The package is formed from a series of small pieces, and is somewhat
+unstructured.  The user who looks for thought-through verbatim facilities is
+advised to consider using the @code{fancyvrb} package in place of
+@code{moreverb}.")
+    (license license:lppl)))
+
 (define-public texlive-namedef
   (package
     (name "texlive-namedef")