summary refs log tree commit diff
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:40 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:50 +0200
commitb05edff0b2ba5f698e677bc36d80e33779312048 (patch)
tree0b1951c00552b8d00f885ffc010d17906e898f72
parentd6056cc7fec16764c5212c8df9cc33fb201690aa (diff)
downloadguix-b05edff0b2ba5f698e677bc36d80e33779312048.tar.gz
gnu: Add xfce4-stopwatch-plugin.
* gnu/packages/xfce.scm (xfce4-stopwatch-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/xfce.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index aaae28fa9a..225ecbbc01 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1650,6 +1650,35 @@ directly to your browser, such that you can search through your
 favorite search engine or bug tracker right from the Xfce panel.")
     (license gpl2+)))
 
+(define-public xfce4-stopwatch-plugin
+  (package
+   (name "xfce4-stopwatch-plugin")
+   (version "0.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-stopwatch-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-stopwatch-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "07dadvgivly44w7qj74i2w60nk01h8567paxrli8vzmhb3p6xi2h"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; test fails in po/ directory
+     `(#:tests? #f))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-stopwatch-plugin")
+    (synopsis "Stopwatch plugin for the Xfce panel")
+    (description "This Xfce panel plugin keeps track of elapsed time.")
+    (license bsd-2)))
+
 (define-public xfce4-systemload-plugin
   (package
    (name "xfce4-systemload-plugin")