summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-28 23:32:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-29 09:30:32 +0200
commitb4c86e6dbc828288fec8966f05d2291d78055525 (patch)
tree435908c7e430fbdb05458afc9794a09c9cc9ef90
parent29a1c93b72b6b29605c902ecc317596f845e94ae (diff)
downloadguix-b4c86e6dbc828288fec8966f05d2291d78055525.tar.gz
gnu: graphviz-2.38: Fix build failure.
* gnu/packages/graphviz.scm
  (graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/graphviz.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 3bfbcb2250..dbfc66960e 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -150,19 +150,20 @@ interfaces for other technical domains.")
       (arguments
        (substitute-keyword-arguments (package-arguments graphviz)
          ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'unpack 'prepare-bootstrap
-               (lambda _
-                 (substitute* "autogen.sh"
-                   (("/bin/sh") (which "sh"))
-                   (("\\$GRAPHVIZ_VERSION_DATE") "0"))
-                 (setenv "CONFIG_SHELL" (which "sh"))
-                 (setenv "SHELL" (which "sh"))
+          #~(modify-phases #$phases
+              (add-after 'unpack 'prepare-bootstrap
+                (lambda _
+                  (substitute* "autogen.sh"
+                    (("/bin/sh") (which "sh"))
+                    (("\\$GRAPHVIZ_VERSION_DATE") "0"))
+                  (setenv "CONFIG_SHELL" (which "sh"))
+                  (setenv "SHELL" (which "sh"))
 
-                 (map make-file-writable (find-files "." ".*"))
-                 #t))
-             (replace 'bootstrap
-               (lambda _ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
+                  (map make-file-writable (find-files "." ".*"))
+                  #t))
+              (replace 'bootstrap
+                (lambda _
+                  (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
       (native-inputs
        `(("autoconf" ,autoconf)
          ("automake" ,automake)