summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-12 18:22:37 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-12 18:25:00 +0100
commitb828057ea4c096898da8c9810e7a6607359f2aa3 (patch)
tree99eade66005469ba5faaf1ff69f61b3f3e659567
parentea50795d7f54582d5c439f60e836ff2ee5d8aed2 (diff)
downloadguix-b828057ea4c096898da8c9810e7a6607359f2aa3.tar.gz
gnu: KDE: Fix old cgit home-pages.
Fix all home-pages pointing to git-repos a cgit.kde.org, which is
gone, to now use the correct repo at invent.kde.org.

* gnu/packages/kde.scm (grantleetheme, kdiagram): Update home-page.
* gnu/packages/kde-frameworks.scm (kholidays): Likewise.
* gnu/packages/kde-internet.scm (libgravatar, libktorrent): Likewise.
* gnu/packages/kde-multimedia.scm (libkcddb, libkcompactdisc): Likewise.
* gnu/packages/kde-pim.scm (kblog, kdav, kdepim-apps-libs,
  kdepim-runtime, keventviews, kincidenceeditor, kmailcommon,
  kmailimporter, kmessagelib, kpimcommon, ksmtp, libkdepim, libkgapi,
  libkleo, libksieve): Likewise.
* gnu/packages/kde-plasma.scm (kdecoration, kscreenlocker): Likewise.
-rw-r--r--gnu/packages/kde-frameworks.scm2
-rw-r--r--gnu/packages/kde-internet.scm4
-rw-r--r--gnu/packages/kde-multimedia.scm4
-rw-r--r--gnu/packages/kde-pim.scm30
-rw-r--r--gnu/packages/kde-plasma.scm4
-rw-r--r--gnu/packages/kde.scm4
6 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index febdb1f4f0..951a2f8554 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -811,7 +811,7 @@ interfaces in the areas of colors, fonts, text, images, keyboard input.")
     (inputs
      `(("qtbase" ,qtbase)
        ("qtdeclarative" ,qtdeclarative)))
-    (home-page "https://cgit.kde.org/kholidays.git")
+    (home-page "https://invent.kde.org/frameworks/kholidays")
     (synopsis "Library for regional holiday information")
     (description "This library provides a C++ API that determines holiday and
 other special events for a geographical region.")
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index 4203ffbaec..617937002e 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -450,7 +450,7 @@ a full-featured client for BitTorrent.")
        ("qtbase" ,qtbase)))
     (arguments
      `(#:tests? #f)) ;; 2/7 tests fail (due to network issues?)
-    (home-page "https://cgit.kde.org/libgravatar.git")
+    (home-page "https://invent.kde.org/pim/libgravatar")
     (synopsis "Online avatar lookup library")
     (description "This library retrieves avatar images based on a
 hash from a person's email address, as well as local caching to avoid
@@ -484,7 +484,7 @@ unnecessary network operations.")
        ("qca" ,qca)
        ("qtbase" ,qtbase)
        ("solid" ,solid)))
-    (home-page "https://cgit.kde.org/libktorrent.git")
+    (home-page "https://invent.kde.org/network/libktorrent")
     (synopsis "BitTorrent protocol library for C++ / Qt 5 / KDE Frameworks")
     (description "The KTorrent library supports connectivity to HTTP and UDP
 trackers, mainline DHT and the new generation Micro Transport
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index 23417a982d..cc312b6c40 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -695,7 +695,7 @@ Its features include:
        ("qtbase" ,qtbase)))
     (arguments
      `(#:tests? #f)) ; Most tests require network
-    (home-page "https://cgit.kde.org/libkcddb.git")
+    (home-page "https://invent.kde.org/multimedia/libkcddb")
     (synopsis "CDDB library for KDE Platform (runtime)")
     (description "A library for retrieving and sending cddb information.")
     (license ;; GPL for programs, LGPL for libraries, FDL for documentation
@@ -722,7 +722,7 @@ Its features include:
        ("phonon" ,phonon)
        ("qtbase" ,qtbase)
        ("solid" ,solid)))
-    (home-page "https://cgit.kde.org/libkcompactdisc.git/")
+    (home-page "https://invent.kde.org/multimedia/libkcompactdisc")
     (synopsis "KDE library for playing & ripping CDs")
     (description "The KDE Compact Disc library provides an API for
 applications using the KDE Platform to interface with the CD drives for audio
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 4ef49743fe..b0a2e565ed 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -391,7 +391,7 @@ Akonadi PIM data server.  It uses Xapian for indexing and querying.")
        ("kwallat" ,kwallet)
        ("libkdepim" ,libkdepim)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/incidenceeditor.git")
+    (home-page "https://invent.kde.org/pim/incidenceeditor")
     (synopsis "KDE PIM library for editing incidences")
     (description "This library provides an incidence editor for KDE PIM.")
     (license ;; GPL for programs, LGPL for libraries
@@ -518,7 +518,7 @@ calendar data.")
        ("qtbase" ,qtbase)
        ("syndication" ,syndication)))
     ;; Note: Some tests take up to 90 sec.
-    (home-page "https://cgit.kde.org/kblog.git")
+    (home-page "https://invent.kde.org/pim/kblog")
     (synopsis "Client-side support library for web application remote blogging
 APIs")
     (description "KBlog is a library for calling functions on Blogger 1.0,
@@ -634,7 +634,7 @@ functions for accessing calendar data using the kcalcore API.")
        ("kio" ,kio)
        ("qtbase" ,qtbase)
        ("qtxmlpatterns" ,qtxmlpatterns)))
-    (home-page "https://cgit.kde.org/kdav.git")
+    (home-page "https://invent.kde.org/frameworks/kdav")
     (synopsis "DAV protocol implementation with KJobs")
     (description "This is a DAV protocol implementation with KJobs.  Calendars
 and todos are supported, using either GroupDAV or CalDAV, and contacts are
@@ -679,7 +679,7 @@ supported using GroupDAV or CardDAV.")
        ("prison" ,prison)
        ("qgpgme" ,qgpgme)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/kdepim-apps-libs.git")
+    (home-page "https://invent.kde.org/pim/kdepim-apps-libs")
     (synopsis "KDE PIM mail related libraries and data files")
     (description "This package provides mail related libraries and data files
 for KDE PIM.")
@@ -761,7 +761,7 @@ for KDE PIM.")
                                              "/include/KF5:"
                                              (or (getenv "CPLUS_INCLUDE_PATH") "")))
                       #t)))))
-    (home-page "https://cgit.kde.org/kdepim-runtime.git")
+    (home-page "https://invent.kde.org/pim/kdepim-runtime")
     (synopsis "Runtime components for Akonadi KDE")
     (description "This package contains Akonadi agents written using KDE
 Development Platform libraries.  Any package that uses Akonadi should probably
@@ -816,7 +816,7 @@ package.")
        ("kxmlgui" ,kxmlgui)
        ("libkdepim" ,libkdepim)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/eventviews.git")
+    (home-page "https://invent.kde.org/pim/eventviews")
     (synopsis "KDE PIM library for creating events")
     (description "This library provides an event creator for KDE PIM.")
     (license ;; GPL for programs, LGPL for libraries
@@ -1180,7 +1180,7 @@ manager from KDE.")
        ("qtbase" ,qtbase)))
     (arguments
      `(#:tests? #f))  ;; TODO: 4/56 tests fail, even with "offscreen" and dbus
-    (home-page "https://cgit.kde.org/mailcommon.git")
+    (home-page "https://invent.kde.org/pim/mailcommon")
     (synopsis "KDE email utility library")
     (description "The mail common library provides utility functions for
 dealing with email.")
@@ -1219,7 +1219,7 @@ dealing with email.")
        ("kxmlgui" ,kxmlgui)
        ("libkdepim" ,libkdepim)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/mailimporter.git")
+    (home-page "https://invent.kde.org/pim/mailimporter")
     (synopsis "KDE mail importer library")
     (description "This package provides libraries for importing mails other
 e-mail client programs into KMail and KDE PIM.")
@@ -1373,7 +1373,7 @@ using a Qt/KMime C++ API.")
                                              "/include/KF5:"
                                              (or (getenv "CPLUS_INCLUDE_PATH") "")))
                       #t)))))
-    (home-page "https://cgit.kde.org/messagelib.git")
+    (home-page "https://invent.kde.org/pim/messagelib")
     (synopsis "KDE PIM messaging libraries")
     (description "This package provides several libraries for messages,
 e.g. a message list, a mime tree parse, a template parser and the
@@ -1701,7 +1701,7 @@ Virtual Contact File}) files to the KPeople contact management library.")
        ("qtwebengine" ,qtwebengine)))
     (arguments
      `(#:tests? #f)) ;; TODO tests hang
-    (home-page "https://cgit.kde.org/pimcommon.git")
+    (home-page "https://invent.kde.org/pim/pimcommon")
     (synopsis "Common libraries for KDE PIM")
     (description "This package provides common libraries for KDE PIM.")
     (license ;; GPL for programs, LGPL for libraries
@@ -1782,7 +1782,7 @@ text in the text edit to all kinds of markup, like HTML or BBCODE.")
                  _ prefix)
                 (string-append prefix "${KDE_INSTALL_TARGETS_DEFAULT_ARGS})")))
              #t)))))
-    (home-page "https://cgit.kde.org/ksmtp.git")
+    (home-page "https://invent.kde.org/pim/ksmtp")
     (synopsis "Library for sending email through an SMTP server")
     (description "This library provides an API for handling SMTP
 services.  SMTP (Simple Mail Transfer Protocol) is the most prevalent Internet
@@ -1863,7 +1863,7 @@ and allows one to view/extract message formatted text in Rich Text Format.")
        ("kwallet" ,kwallet)
        ("kwidgetsaddons" ,kwidgetsaddons)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/libkdepim.git")
+    (home-page "https://invent.kde.org/pim/libkdepim")
     (synopsis "Libraries for common KDE PIM apps")
     (description "This package provided libraries for common KDE PIM apps.")
     (license ;; GPL for programs, LGPL for libraries
@@ -1898,7 +1898,7 @@ and allows one to view/extract message formatted text in Rich Text Format.")
        ("qtwebengine" ,qtwebengine)))
     (arguments
      `(#:tests? #f)) ;; TODO 6/48 tests fail
-    (home-page "https://cgit.kde.org/libkgapi.git")
+    (home-page "https://invent.kde.org/pim/libkgapi")
     (synopsis "Library for accessing various Google services via their public
 API")
     (description "@code{LibKGAPI} is a C++ library that implements APIs for
@@ -1936,7 +1936,7 @@ various Google services.")
        ("kpimtextedit" ,kpimtextedit)
        ("qgpgme" ,qgpgme)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/libkleo.git/")
+    (home-page "https://invent.kde.org/pim/libkleo")
     (synopsis "KDE PIM cryptographic library")
     (description "@code{libkleo} is a library for Kleopatra and other parts of
 KDE using certificate-based crypto.")
@@ -1999,7 +1999,7 @@ KDE using certificate-based crypto.")
                ((".*sieveeditorgraphicalmodewidgettest\\.cpp.*")
                 ""))
              #t)))))
-    (home-page "https://cgit.kde.org/libksieve.git")
+    (home-page "https://invent.kde.org/pim/libksieve")
     (synopsis "KDE Sieve library")
     (description "Sieve is a language that can be used filter emails.  KSieve
 is a Sieve parser and interpreter library for KDE.")
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index c53f6b29c7..e18d521ad2 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -52,7 +52,7 @@
     (inputs
      `(("ki18n" ,ki18n)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/kdecoration.git")
+    (home-page "https://invent.kde.org/plasma/kdecoration")
     (synopsis "Plugin based library to create window decorations")
     (description "KDecoration is a library to create window decorations.
 These window decorations can be used by for example an X11 based window
@@ -119,7 +119,7 @@ manager which re-parents a Client window to a window decoration frame.")
        ("solid" ,solid)
        ("wayland" ,wayland)
        ("xcb-util-keysyms" ,xcb-util-keysyms)))
-    (home-page "https://cgit.kde.org/kscreenlocker.git")
+    (home-page "https://invent.kde.org/plasma/kscreenlocker")
     (synopsis "Screen locking library")
     (description
      "@code{kscreenlocker} is a library for creating secure lock screens.")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 1f747ecfd4..601b2bba8b 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -130,7 +130,7 @@ This package contains GUI widgets for baloo.")
        ("kiconthemes" ,kiconthemes)
        ("knewstuff" ,knewstuff)
        ("qtbase" ,qtbase)))
-    (home-page "https://cgit.kde.org/grantleetheme.git")
+    (home-page "https://invent.kde.org/pim/grantleetheme")
     (synopsis "Library providing Grantlee theme support")
     (description "This library provides Grantlee theme support.")
     (license ;; LGPL for libraries, FDL for documentation
@@ -362,7 +362,7 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
     (inputs
      `(("qtbase" ,qtbase)
        ("qtsvg" ,qtsvg)))
-    (home-page "https://cgit.kde.org/kdiagram.git/")
+    (home-page "https://invent.kde.org/graphics/kdiagram")
     (synopsis "Libraries for creating business diagrams")
     (description "This package provides libraries for integrating business
 diagrams in Qt-based applications.