summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 17:35:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 17:35:28 +0100
commitbd100c7112b1717881ff6efcaa514be5cfeb5349 (patch)
tree923232f66ca520ba9a55eb4f7aa72dee1b1a3bdb
parent497355dc09449426ef4fda521433002ec93c4796 (diff)
downloadguix-bd100c7112b1717881ff6efcaa514be5cfeb5349.tar.gz
gnu: python-hypothesis: Don't propagate test inputs.
* gnu/packages/python.scm (python-hypothesis,
  python2-hypothesis)[propagated-inputs]: Move everything from here ...
  [native-inputs]: ... to here.
(python2-hypothesis)[native-inputs]: Append inherited native-inputs.
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 540a988234..cd6ed1c240 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8544,7 +8544,7 @@ Amazon Web Services (AWS) API.")
                (base32
                 "0qyqq9akm4vshhn8cngjc1qykcvsn7cz6dlm6njfsgpbraqrmbbw"))))
     (build-system python-build-system)
-    (propagated-inputs
+    (native-inputs
      `(("python-flake8" ,python-flake8)
        ("python-pytest" ,python-pytest)))
     (synopsis "Library for property based testing")
@@ -8561,7 +8561,8 @@ seamlessly into your existing Python unit testing work flow.")
                      (strip-python2-variant python-hypothesis))))
     (package (inherit hypothesis)
       (native-inputs
-       `(("python2-enum34" ,python2-enum34))))))
+       `(("python2-enum34" ,python2-enum34)
+         ,@(package-native-inputs hypothesis))))))
 
 (define-public python-pytest-subtesthack
   (package