summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-17 22:31:42 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-17 23:14:54 +0100
commitbead6dcb58f8e3f907ae4421e42b9e5e26bb2c24 (patch)
tree3e4e41259af89c361075f63469198abf16d2a5fd
parent6ba6a1c103ea94f2c9a984db466c3b2829e8f175 (diff)
downloadguix-bead6dcb58f8e3f907ae4421e42b9e5e26bb2c24.tar.gz
gnu: slurm: Allow builds on 32-bit platforms.
Fixes a regression introduced in
7c96befa52ba127f68a066162258e600afbc73fb whereby ./configure would fail
on 32-bit platforms due to 32-bit support being "deprecated".

* gnu/packages/parallel.scm (slurm)[arguments]: Pass
"--enable-deprecated" configure flag unless 'target-64bit?' returns
true.
-rw-r--r--gnu/packages/parallel.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 4fc2c9afb4..98721fe1ff 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -32,6 +32,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module ((guix utils) #:select (target-64bit?))
   #:use-module (guix packages)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
@@ -158,7 +159,11 @@ and they are executed on lists of files, hosts, users or other items.")
             (string-append "--with-freeipmi=" (assoc-ref %build-inputs "freeipmi"))
             (string-append "--with-hwloc=" (assoc-ref %build-inputs "hwloc"))
             (string-append "--with-json=" (assoc-ref %build-inputs "json-c"))
-            (string-append "--with-munge=" (assoc-ref %build-inputs "munge")))
+            (string-append "--with-munge=" (assoc-ref %build-inputs "munge"))
+
+            ;; 32-bit support is marked as deprecated and needs to be
+            ;; explicitly enabled.
+            ,@(if (target-64bit?) '() '("--enable-deprecated")))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'autoconf