summary refs log tree commit diff
diff options
context:
space:
mode:
authorStefan Stefanović <stefanx2ovic@gmail.com>2019-06-03 18:27:21 +0200
committerRutger Helling <rhelling@mykolab.com>2019-06-07 09:45:46 +0200
commitbedb3457752212328ee2a0df99280dca36c7f11c (patch)
tree581f3e544a7bbbfd793048282f49f5c8ab1012a0
parent11bca5336cbac2103d9b95a0fb3f686bea6b9ab0 (diff)
downloadguix-bedb3457752212328ee2a0df99280dca36c7f11c.tar.gz
gnu: Add swaybg.
* gnu/packages/wm.scm (swaybg): New variable.

Signed-off-by: Rutger Helling <rhelling@mykolab.com>
-rw-r--r--gnu/packages/wm.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 1e26830763..f0589e98f1 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1279,3 +1279,29 @@ modules for building a Wayland compositor.")
     (synopsis "Screen locking utility for Wayland compositors")
     (description "Swaylock is a screen locking utility for Wayland compositors.")
     (license license:expat))) ; MIT license
+
+(define-public swaybg
+  (package
+    (name "swaybg")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/swaywm/swaybg.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1lmqz5bmig90gq2m7lwf02d2g7z4hzf8fhqz78c8vk92c6p4xwbc"))))
+    (build-system meson-build-system)
+    (inputs `(("cairo" ,cairo)
+              ("gdk-pixbuf" ,gdk-pixbuf)
+              ("wayland" ,wayland)))
+    (native-inputs `(("git" ,git)
+                     ("pkg-config" ,pkg-config)
+                     ("scdoc" ,scdoc)
+                     ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://github.com/swaywm/sway")
+    (synopsis "Screen wallpaper utility for Wayland compositors")
+    (description "Swaybg is a wallpaper utility for Wayland compositors.")
+    (license license:expat))) ; MIT license