summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-08-01 01:22:50 -0500
committerjgart <jgart@dismail.de>2023-08-01 01:33:10 -0500
commitc01235a922807fac02d629275bbafbe7cf326d89 (patch)
treed6b3caa7851a4c032348b8efeb27aa2403928129
parentf8724820439efad1c15801701be19bc1f7eae471 (diff)
downloadguix-c01235a922807fac02d629275bbafbe7cf326d89.tar.gz
gnu: Add python-pyment
 * gnu/packages/python-xyz.scm (python-pyment): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e7236c075c..b8e8097c7b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,7 +99,7 @@
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
-;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2023 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
@@ -5764,6 +5764,28 @@ which only supports flat sequences, and allows you to apply a function to each
 leaf preserving the overall structure.")
     (license license:asl2.0)))
 
+(define-public python-pyment
+  (package
+    (name "python-pyment")
+    (version "0.3.4")
+    (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/dadadel/pyment")
+           (commit (string-append "v" version))))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0gbx9wmqsxdx85v5sg79lv2zxmy16j5dwi8bip07i1nyvzc5gvn0"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/dadadel/pyment/")
+    (synopsis "Convert Python docstrings automatically")
+    (description "Pyment is a command line tool and library that can be
+used to convert between several docstring styles.")
+    (license license:gpl3+)))
+
 (define-public python-docstring-parser
   (package
     (name "python-docstring-parser")