summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 15:47:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 15:47:57 +0200
commitc125119204a0084c52b78fe902a6f0fb75869c7e (patch)
tree0e689968060666568374d5a4ff1df074e8d30157
parent8951b9496b5c390adb3b3292d234bb8ab9936c40 (diff)
downloadguix-c125119204a0084c52b78fe902a6f0fb75869c7e.tar.gz
gnu: emacs-ebdb: Update to 0.6.18.
* gnu/packages/emacs-xyz.scm (emacs-ebdb): Update to 0.6.18.
[source]: Use GNU ELPA repository instead of GitHub.
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 18 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df5f47a495..79dcddc60b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21033,30 +21033,25 @@ time.")
 federated microblogging social network.")
     (license license:gpl3+)))
 
-;; The last release tarball is for version 0.6.  We pick a commit close to
-;; version 0.6.10, which doesn't have a release tarball.
 (define-public emacs-ebdb
-  (let ((commit "2a87f5ed2a53e3a4e91e8c88ba5afc49f5e945df")
-        (revision "0"))
-    (package
-      (name "emacs-ebdb")
-      (version (git-version "0.6.10" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/girzel/ebdb.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0fidy7z0c86dpqiss97sg5s92fd3fj4bdl8pqqdgg2m00jx4mrjz"))))
-      (build-system emacs-build-system)
-      (home-page "https://github.com/girzel/ebdb")
-      (synopsis "EIEIO port of BBDB, Emacs's contact-management package")
-      (description "EBDB is a contact management/addressbook package for
-Emacs.  It's a re-write of the Insidious Big Brother Database (BBDB) using
-Emacs Lisp's (relatively new) EIEIO object oriented libraries.")
-      (license license:gpl3+))))
+  (package
+    (name "emacs-ebdb")
+    (version "0.6.18")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/"
+                           "ebdb-" version ".tar"))
+       (sha256
+        (base32 "0znbv3c7wdgak1f1zb051vg4r29fksqh53k1j77jfmqcvwkpz2mw"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/girzel/ebdb")
+    (synopsis "EIEIO port of BBDB, Emacs's contact-management package")
+    (description
+     "EBDB is a contact management/addressbook package for Emacs.  It's
+a re-write of the Insidious Big Brother Database (BBDB) using Emacs
+Lisp's (relatively new) EIEIO object oriented libraries.")
+    (license license:gpl3+)))
 
 (define-public emacs-refactor
   (package