summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:42:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:30:58 +0300
commitc5050528ea7c52daad7697afa538a954163e5ec1 (patch)
tree26319526e45352a1e0e7ee3c01334108cbe1d3b4
parent00f5b065b5159aa3987731850a56dd067a070f60 (diff)
downloadguix-c5050528ea7c52daad7697afa538a954163e5ec1.tar.gz
gnu: Add rust-autocfg-0.1.
* gnu/packages/rust-cbindgen.scm (rust-autocfg-0.1): New hidden
variable.
-rw-r--r--gnu/packages/rust-cbindgen.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index c37b80ecc6..35bc6b04df 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -62,3 +62,26 @@ text or blue underlined text, on ANSI terminals.")
      "This package provides a simple interface for querying atty.")
     (properties '((hidden? . #t)))
     (license license:expat)))
+
+(define rust-autocfg-0.1
+  (package
+    (name "rust-autocfg")
+    (version "0.1.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "autocfg" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "1chwgimpx5z7xbag7krr9d8asxfqbh683qhgl9kn3hxk2l0djj8x"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/cuviper/autocfg")
+    (synopsis "Automatic cfg for Rust compiler features")
+    (description "Rust library for build scripts to automatically configure
+code based on compiler support.  Code snippets are dynamically tested to see
+if the @code{rustc} will accept them, rather than hard-coding specific version
+support.")
+    (properties '((hidden? . #t)))
+    (license (list license:asl2.0
+                   license:expat))))