summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-28 10:53:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-28 11:25:17 +0200
commitc8f16c7f7e043bdcfbdffdd09909778adecb9160 (patch)
treeea1690e8809a4b2aab472db9284fb2a5df127198
parent4d85a7dd26c06b22e7fcafc0855a6a84df3a38dd (diff)
downloadguix-c8f16c7f7e043bdcfbdffdd09909778adecb9160.tar.gz
gnu: ocaml-ctypes: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-ctypes)[source]: Download using git-fetch.
[arguments]: Add phase to make files writable.
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 65d89bca26..32b03359d8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3254,12 +3254,14 @@ long and size_t whose sizes depend on the host platform.")
    (version "0.14.0")
    (home-page "https://github.com/ocamllabs/ocaml-ctypes")
    (source (origin
-             (method url-fetch)
-             (uri (string-append home-page "/archive/" version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
+             (method git-fetch)
+             (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "0zrsd42q2nciyg9375g2kydqax6ay299rhyfgms59qiw7d9ylyp9"))))
+               "1b2q3h63ngf4x9qp65qwapf2dg9q0mcdah6qjm2q0c7v2p5vysv9"))))
    (build-system ocaml-build-system)
    (arguments
     `(#:tests? #f; require an old lwt
@@ -3267,6 +3269,14 @@ long and size_t whose sizes depend on the host platform.")
       (list (string-append "INSTALL_HEADERS = $(wildcard $($(PROJECT).dir)/*.h)"))
       #:phases
       (modify-phases %standard-phases
+        (add-after 'unpack 'make-writable
+          (lambda _
+            (for-each
+              (lambda (file)
+                (let ((stat (stat file)))
+                  (chmod file (+ #o200 (stat:mode stat)))))
+              (find-files "." "."))
+            #t))
         (delete 'configure))))
    (native-inputs
     `(("pkg-config" ,pkg-config)))