summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:28:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:38:32 +0100
commitcbfa23c74ec874be7f55ee7758009d477d6c6005 (patch)
tree05511d92832fe32fd9547a73fb5149a89030d7d2
parentbb2d1dae20d5a0debc8fde405c34f4f16f189198 (diff)
downloadguix-cbfa23c74ec874be7f55ee7758009d477d6c6005.tar.gz
gnu: python-pycryptodomex: Inherit from python-pycryptodome.
* gnu/packages/python-crypto.scm (python-pycryptodomex): Inherit from
python-pycryptodome.
[build-system, home-page, synopsis, license]: Remove redundant fields.
-rw-r--r--gnu/packages/python-crypto.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 60a9776bae..ce183bd6ae 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1042,18 +1042,15 @@ PyCryptodome variants, the other being python-pycryptodomex.")
   (package-with-python2 python-pycryptodome))
 
 (define-public python-pycryptodomex
-  (package
+  (package (inherit python-pycryptodome)
     (name "python-pycryptodomex")
-    (version "3.9.9")
+    (version (package-version python-pycryptodome))
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pycryptodomex" version))
        (sha256
         (base32 "0lbx4qk3xmwqiidhmkj8qa7bh2lf8bwzg0xjpsh2w5zqjrc7qnvv"))))
-    (build-system python-build-system)
-    (home-page "https://www.pycryptodome.org")
-    (synopsis "Low-level cryptographic Python library")
     (description
      "PyCryptodome is a self-contained Python package of low-level
 cryptographic primitives.  It's not a wrapper to a separate C library like
@@ -1088,9 +1085,7 @@ in userspace)
 @end itemize
 
 PyCryptodomex is the stand-alone version of PyCryptodome that no longer
-provides drop-in compatibility with PyCrypto.")
-    (license (list license:bsd-2
-                   license:public-domain)))) ; code inherited from PyCrypto
+provides drop-in compatibility with PyCrypto.")))
 
 (define-public python-m2crypto
   (package