summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-13 19:07:30 +0100
committerLeo Famulari <leo@famulari.name>2016-12-13 17:04:19 -0500
commitcff0ccf9dce5bb0c6c504909be7dfc581f3068a9 (patch)
tree464ddddef121e33e1b75d20aa37a94a71478f4a4
parent97be1bc23128cf42c49867d984c43f6fea3820d6 (diff)
downloadguix-cff0ccf9dce5bb0c6c504909be7dfc581f3068a9.tar.gz
gnu: python-requests: Disable tests.
* gnu/packages/python.scm (python-requests, python2-requests,
python-requests-2.7)[native-inputs]: Remove field.
[arguments]: New field. Set #:tests? #f.
-rw-r--r--gnu/packages/python.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1a8a9a407c..200ba30498 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2365,12 +2365,11 @@ installed with a newer @code{pip} or with wheel's own command line utility.")
              (sha256
               (base32
                "0zsqrzlybf25xscgi7ja4s48y2abf9wvjkn47wh984qgs1fq2xy5"))))
+    ;; TODO: unbundle urllib3 and chardet.
     (build-system python-build-system)
-    (native-inputs
-     `(("python-py" ,python-py)
-       ("python-pytest" ,python-pytest)
-       ("python-pytest-cov" ,python-pytest-cov)
-       ("python-wheel" ,python-wheel)))
+    (arguments
+     ;; FIXME: Some tests require network access.
+     '(#:tests? #f))
     (home-page "http://python-requests.org/")
     (synopsis "Python HTTP library")
     (description