summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 21:45:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:23 +0200
commitd26563323d8559dcbb04621ccab02e07767abb6e (patch)
tree012d006319a3e0bc8593dc83962258fcb19a1afa
parent7c1a64aa5c7d276cb1c34317f77535afec268b9e (diff)
downloadguix-d26563323d8559dcbb04621ccab02e07767abb6e.tar.gz
gnu: corkscrew: Deduplicate documentation directories.
* gnu/packages/ssh.scm (corkscrew)[arguments]: Install documentation to
the correct versioned subdirectory, as already done by the build system.
-rw-r--r--gnu/packages/ssh.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 1240216ec7..caa8c783ea 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -331,7 +331,7 @@ libssh library.")
     (arguments
      ;; Replace configure phase as the ./configure script does not link
      ;; CONFIG_SHELL and SHELL passed as parameters
-     '(#:phases
+     `(#:phases
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key outputs inputs system build target
@@ -351,7 +351,7 @@ libssh library.")
          (add-after 'install 'install-documentation
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
-                    (doc (string-append out "/share/doc/corkscrew")))
+                    (doc (string-append out "/share/doc/" ,name "-" ,version)))
                (install-file "README" doc)
                #t))))))
     (home-page "http://www.agroman.net/corkscrew")