summary refs log tree commit diff
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-07-10 18:06:09 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-13 00:08:55 +0200
commitd2c5e91278f2589e13390ee29630e593fbf41d22 (patch)
tree3a0367b4278cb206409fb593328bd792aff706a3
parentabd47216b70d6590322a75e6d6f7e85639c82077 (diff)
downloadguix-d2c5e91278f2589e13390ee29630e593fbf41d22.tar.gz
gnu: Add go-gopkg-in-yaml-v2.
* gnu/packages/golang.scm (go-gopkg-in-yaml-v2): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9393d39d51..92ce504c52 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1947,3 +1947,31 @@ which satisfies the cron expression.")
       (description
        "This package provides a test library for the Go language.")
       (license license:asl2.0))))
+
+(define-public go-gopkg-in-yaml-v2
+  (let ((commit "14227de293ca979cf205cd88769fe71ed96a97e2")
+        (revision "0"))
+    (package
+      (name "go-gopkg-in-yaml-v2")
+      (version (git-version "0.0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://gopkg.in/yaml.v2.git")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+            (base32
+              "038hnrjcnjygyi3qidfrkpkakis82qg381sr495d2s40g2dwlzah"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "gopkg.in/yaml.v2"))
+      (native-inputs
+       `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+      (home-page "https://gopkg.in/yaml.v2")
+      (synopsis "YAML reader and writer for the Go language")
+      (description
+       "This package provides a Go library for encode and decode YAML
+values.")
+      (license license:asl2.0))))