summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-26 20:35:42 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:57 +0100
commitd619480827d414fa7061ed1d22a95ee085c4591c (patch)
tree1daeab0ebc8c3978432a44a53a4214d586075c0f
parent68238b73b346bbf117cafc3bc0b9d00ef4a01e5f (diff)
downloadguix-d619480827d414fa7061ed1d22a95ee085c4591c.tar.gz
gnu: ruby-mocha: Update to 2.0.4.
* gnu/packages/ruby.scm (ruby-mocha): Update to 2.0.4.
[arguments]: Update style.
[propagated-inputs]: Add ruby-ruby2-keywords.
[native-inputs]: Add ruby-psych-3.
(ruby-mocha-1): New variable.
-rw-r--r--gnu/packages/ruby.scm41
1 files changed, 28 insertions, 13 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6a8bcda92a..b23af7caa7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5243,27 +5243,29 @@ number, support for interrupted tests, better backtraces, and more.")
 (define-public ruby-mocha
   (package
     (name "ruby-mocha")
-    (version "1.13.0")
+    (version "2.0.4")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "mocha" version))
               (sha256
                (base32
-                "15s53ggsykk69kxqvs4416s8yxdhz6caggva55n8sjgy4ixzwp10"))))
+                "18xn9gm9yypavy9yck71fplan19hy5697mwd1rwzz7vizh3ip7bd"))))
     (build-system ruby-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'remove-rubocop-dependency
-           (lambda _
-             ;; Disable dependency on Rubocop, which is just a linter,
-             ;; and would introduce a circular dependency.
-             (substitute* "mocha.gemspec"
-               ((".*rubocop.*")
-                "true\n"))
-             #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'remove-rubocop-dependency
+            (lambda _
+              ;; Disable dependency on Rubocop, which is just a linter,
+              ;; and would introduce a circular dependency.
+              (substitute* "Gemfile"
+                ((".*rubocop.*") "")))))))
+    (propagated-inputs
+     (list ruby-ruby2-keywords))
     (native-inputs
-     (list ruby-introspection))
+     (list ruby-psych-3
+           ruby-introspection))
     (synopsis "Mocking and stubbing library for Ruby")
     (description
      "Mocha is a mocking and stubbing library with JMock/SchMock syntax, which
@@ -5272,6 +5274,19 @@ allows mocking and stubbing of methods on real (non-mock) classes.")
     ;; Mocha can be used with either license at the users choice.
     (license (list license:expat license:ruby))))
 
+(define-public ruby-mocha-1
+  (package
+    (inherit ruby-mocha)
+    (version "1.13.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "mocha" version))
+              (sha256
+               (base32
+                "15s53ggsykk69kxqvs4416s8yxdhz6caggva55n8sjgy4ixzwp10"))))
+    (arguments
+     '(#:tests? #f))))
+
 (define-public ruby-mocha-on-bacon
   (package
     (name "ruby-mocha-on-bacon")