summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-08-29 16:45:34 +0200
committerDavid Craven <david@craven.ch>2016-09-01 17:17:42 +0200
commitd62ed73239bf31006ac9a7bcc0887db8696e4f1f (patch)
treec0f3af9311d64761260ddf7714bf2ff4bba0e493
parente5cd149f681cc8d285da6c7638b70a43b333f337 (diff)
downloadguix-d62ed73239bf31006ac9a7bcc0887db8696e4f1f.tar.gz
gnu: Add dtc.
* gnu/packages/u-boot.scm (dtc): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add file.

Co-authored-by: David Craven <david@craven.ch>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/u-boot.scm60
2 files changed, 61 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5b90dfbfdd..8179920163 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -348,6 +348,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/unrtf.scm			\
   %D%/packages/upnp.scm				\
   %D%/packages/uucp.scm				\
+  %D%/packages/u-boot.scm			\
   %D%/packages/valgrind.scm			\
   %D%/packages/version-control.scm		\
   %D%/packages/video.scm			\
diff --git a/gnu/packages/u-boot.scm b/gnu/packages/u-boot.scm
new file mode 100644
index 0000000000..83e42f08c3
--- /dev/null
+++ b/gnu/packages/u-boot.scm
@@ -0,0 +1,60 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2016 David Craven <david@craven.ch>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages u-boot)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages flex))
+
+(define-public dtc
+  (package
+    (name "dtc")
+    (version "1.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://www.kernel.org/pub/software/utils/dtc/"
+                    "dtc-" version ".tar.xz"))
+              (sha256
+               (base32
+                "155v52palf5fwfcnq696s41whjk0a5dqx98b7maqzdn7xbc2m6bp"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("bison" ,bison)
+       ("flex" ,flex)))
+    (arguments
+     `(#:make-flags
+       (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-paths
+           (lambda _
+             (substitute* "Makefile"
+               (("/usr/bin/install") "install"))
+             (substitute* "Makefile"
+               (("PREFIX = \\$\\(HOME\\)") ""))))
+         (delete 'configure))))
+    (home-page "https://www.devicetree.org")
+    (synopsis "Compiles device tree source files")
+    (description "@command{dtc} compiles device tree source files to device
+tree binary files. These are board description files used by Linux and BSD.")
+    (license license:gpl2+)))