summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 13:58:25 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-10-09 13:09:50 +0300
commitda069d7eccb67d4363a7052b676e2c3e4dc2ceec (patch)
tree0a61f604c6b54dc208786694aec5649483ff8c3e
parent7e67fdd1f3dcc0f7741b6e6a7b6b3f026560f058 (diff)
downloadguix-da069d7eccb67d4363a7052b676e2c3e4dc2ceec.tar.gz
gnu: Add python-feedparser.
* gnu/packages/python.scm (python-feedparser): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 667d2cdf25..cabf1e6b49 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -45,6 +45,7 @@
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system r)
   #:use-module (guix build-system trivial)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages apr)
   #:use-module (gnu packages documentation)
@@ -3148,6 +3149,34 @@ http://opensearch.a9.com} compatible search engines.")
 their web site.")
     (home-page "http://search.cpan.org/~gaas/WWW-RobotRules/")))
 
+(define-public python-feedparser
+  (package
+    (name "python-feedparser")
+    (version "5.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "feedparser" version ".tar.bz2"))
+       (sha256
+        (base32
+         "00hb4qg2am06g81mygfi1jsbx8830024jm45g6qp9g8fr6am91yf"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/kurtmckee/feedparser")
+    (synopsis "Parse feeds in Python")
+    (description
+     "Universal feed parser which handles RSS 0.9x, RSS 1.0, RSS 2.0,
+CDF, Atom 0.3, and Atom 1.0 feeds.")
+    (license (list l:bsd-2 ; source code
+                   l:freebsd-doc)))) ; documentation
+
+(define-public python2-feedparser
+  (let ((base (package-with-python2
+               (strip-python2-variant python-feedparser))))
+    (package (inherit base)
+             (native-inputs
+              `(("python2-setuptools" ,python2-setuptools))))))
+
 (define-public r-httpuv
   (package
     (name "r-httpuv")